
ADOBE® AFTER EFFECTS® 4.0 READ ME
 
This file contains late-breaking product information, updates to the Adobe After Effects documentation, and 
troubleshooting tips. Please refer to the user guide for installation instructions. For further troubleshooting and 
performance information, see the user guide or online Help. This file includes the following sections:

* Installation Notes
* Undocumented Features
* Third Party Compatibility
* General Notes
* Using After Effects with Mac OS
* Using After Effects with Windows
* Changing settings in the After Effects .ini file

Important: Please complete your registration card and mail it today or use the on-line registration software 
provided with Adobe After Effects software to register your copy. You must register to receive technical support 
and important product update information.
 

INSTALLATION NOTES

To use After Effects' QuickTime™ features, Apple's QuickTime 3.0 or later must be installed on your computer. 
If it is not already installed, you can find QuickTime for your platform on your After Effects 4.0 CD.

The After Effects Production Bundle installs the latest version of the Sentinel hardware key system drivers 
(v5.37) on Windows. If you use other Sentinel-protected applications such as LightWave 3D, Kinetix 3D Studio 
Max, Avid MCXPress or others, you already have an older version of the Sentinel driver on your system. You 
may wish not to install the newer driver, as it is incompatible with some older software such as Kinetix 3D Studio
MAX 1.0. After Effects Production Bundle will work with the older Sentinel software.

After Effects Production Bundle on Mac OS uses an ADB hardware key. If you are running After Effects on a 
machine without ADB, such as iMac, you can exchange your ADB key for USB hardware. Inside your After 
Effects box is a return envelope and ADB to USB hardware key exchange form – enclose your ADB key and 
follow the return instructions on the form.

Before attaching the hardware key, be sure to power down your computer to avoid damage to the key and your 
computer.

UNDOCUMENTED FEATURES

The following features are incorrectly or incompletely documented elsewhere in the After Effects User Guide 
and/or Quick Reference card.

Keyboard Shortcuts

F2 – deselect all
F3 – open effect controls window

Command-option-keypad-slash (Mac) / Ctrl-Alt-keypad-slash (Windows) – Purge All



Command (Mac) / Ctrl (Windows) drag in free transform mode scales around center point

Alt-keypad-minus (Windows) does not nudge scale as described on the Quick Reference Card. Use Ctrl-keypad-
minus and Ctrl-keypad-plus on Windows to nudge scaling up and down, respectively.

Option/Alt-click on a layer switch (such as video or lock) will change that setting for all selected layers.

Hold down shift when opening a project to suppress opening of all windows (except the project window.)

Shift-comma and Shift-period cycle through tabs in the front-most window. Add option/Alt to zoom the window to
fit.

Option/Alt Delete when a mask is selected removes the mask and all of its keyframes.

Arithmetic Expressions in Dialog Boxes

Most of After Effects' text entry boxes accept simple 2-operator arithmetic expressions. For example, entering 
20*3 is the same as entering 60. Expressions with more than two numbers are not supported.

Time entry boxes do not support arithmetic expressions but do relative time entry – for example, enter +10 in 
the Go To Time dialog to advance ten frames. To perform a relative backwards time entry, use the + sign first. 
For example, entering +-10 in the Go To Time dialog rewinds ten frames, while entering –10 will seek to 10 
frames before time zero.

Using After Effects 4.0 with Adobe Illustrator®

After Effects 4.0 uses a new, faster method for anti-aliasing EPS and Adobe Illustrator files when their layers are
set to best quality. If you experience irregular transparent "bands" or other artifacts in your vector files 
(especially when using color gradients), you can change After Effects' anti-aliasing method to a slower, more 
accurate method:

1. Select the Illustrator/EPS footage file in the project window
2. File>Interpret Footage>Main…
3. Select "Options…"
4. Change the "Anti-aliasing" popup from "Faster" to "More Accurate"

Note that this setting is not retained when using Remember Interpretation and Apply Interpretation. Smooth 
color effects can also be achieved using Adobe Illustrator 8.0's Gradient Mesh feature.

Windowing and Tabbing 

You can set initial positions and tab settings for newly created windows in After Effects, such as the 
Composition, Layer, Footage, Time Layout, Effects, Project and Render Queue Window.

To set a window's initial position:
1. Activate the window
2. Window>Initial Position>Set

To restore a window's position to its default setting:
1. Activate the window
2. Window>Initial Position>Clear

In addition to screen position, some After Effects windows can be grouped with similar windows using tabs. By 
default, each window type opens into a new group; using the tab options you can group Layer and Footage 
windows with Composition windows.



To set a layer/footage window to group with composition windows:
1. Activate the window
2. Window>Initial Position>Group Tab With Comps

You can hide the tabs area of any window by double-clicking on the "rail" underneath the tabs area; this 
collapses the tabs area. When a window is collapsed, other tabs will not open up grouped with it.

Holding Command (Mac) or Ctrl (Windows) while opening a window will force it to open by itself. Dragging a 
window tab with the Command/Ctrl key held down will force the tab to open in its own window.

Additional Preferences

After Effects has a preferences panel (File>Preferences>Cache…) that is not documented in the User Guide or 
online help. 

As you work, After Effects is temporarily storing rendered composition and source images in RAM so that 
previewing and editing can take place more quickly. For example, once you visit a specific frame of a 
composition, it will be kept in RAM (memory permitting) until you change some aspect of the composition that 
would invalidate the rendered image. File>Preferences>Cache… allows you to change settings related to this 
feature. This panel is different on Macintosh and Windows systems.

Macintosh Cache Preferences

To change After Effects' cache mode:
1. File>Preferences>Cache
2. Choose from the Mode Popup

Favor Memory. After Effects will spend time rearranging the cache to pack it efficiently.

Favor Speed. After Effects will not spend time rearranging memory, so rendering may run out of memory 
sooner that it otherwise would, but will be significantly faster.

For fastest rendering, leave this setting at Favor Speed, but if you find that you do not have enough memory to 
render your composition, you can switch to Favor Memory. Regardless of the mode, the cache is compacted 
before every RAM Preview, About After Effects..., and Render Queue rendering.

Windows Cache Preferences

To change After Effects' cache settings:
1. File>Preferences>Cache
2. Enter Values for Cache Size and Maximum Memory Usage

Image Cache Size (percent of installed RAM). This is the maximum amount of memory to use for cached 
frames. The number of frames that RAM Preview displays will be limited to this setting. Increase this setting to 
allow longer RAM previews, decrease it if RAM previews are jerky or halting because of virtual memory paging 
activity. Note that paging depends not just on AE's memory usage, but also the memory usage of all other active
applications. Default value is 60%. Values over 90% are not recommended.

Maximum Memory Usage (percent of installed RAM). This is the maximum amount of memory to use for any
purpose. Increase this limit if you get "insufficient memory" messages. You can go over 100% because virtual 
memory is not limited to installed RAM. Default value is 120%. Values over 200% are not recommended.



Purge Menu

The purge menu (Edit>Purge) lets you manually control when After Effects discards caches and undo 
information. Ordinarily, you should not need to use any options in this menu (After Effects will discard unused 
information from its caches as you work.)

To discard image caches:
1. Choose Edit>Purge>Image Caches

To discard undo/redo information:
1. Choose Edit>Purge>Undo

To purge all nonessential information from memory:
1. Choose Edit>Purge>All

Particle Playground (Production Bundle Only)

Watch the info floater to see how many particles are being generated. Rendering can significantly slow down as 
the number of particles gets over ten thousand.

The Grid and Layer Exploder generate particles on every frame. To avoid continuous particle proliferation, you 
should animate Layer Exploder/Radius of New Particles or Grid/Particle Radius or Font Size down to zero such 
that the new particles are only generated at the start of your sequence.

Particle positions are not limited by the bounds of the layer to which Particle Playground is applied. As such, if 
you are using Selection or Property Maps, you may want to make the map layers larger than the Particle 
Playground layer, so you can control particles that you can't see or that are near the edge of the image. The 
alpha channel of image maps is taken into account when mapping; if you want transparent areas of your map to 
have an effect, precompose the map layer and place a black solid behind it in the pre-comp.

If you plan to field-render with Particle Playground, you should check "Enable Field Rendering" in the options 
dialog box. This tells Particle Playground to calculate the simulation at double the current composition frame 
rate, which is exactly what field rendering will require.

Getting the best results from RAM preview

The performance of RAM preview is a direct result of the performance of your display card. Here are some tips 
for maximizing your RAM preview performance.

Use a high-performance 2D graphics system. Many older display cards or built-in video adapters do not have
sufficient performance to play back full resolution video at full frame rates. Sometimes performance can be 
improved by updating to the newest display drivers available from your display card manufacturer. You can often
achieve full frame rate playback by decreasing your composition's resolution.

Choose the right screen depth. RAM preview performs best when the screen depth (number of colors) 
matches After Effects internal color model; usually this means Millions of Colors on the Macintosh, and True 
Color on Windows. Experiment with different settings to find which is the fastest for your display card.

Match resolution to zoom. RAM preview works at all resolutions and zoom factors, but it performs best when 
the magnification and the zoom factor match. For example, if you generally work in your composition at half 
resolution, you will get the best playback performance when your Composition window is viewed at 50%.

Avoid overlapping windows. RAM preview performance will degrade if any windows are covering the 
Composition image area; After Effects will automatically hide any of its palettes which overlap, but look out for 
system windows such as the Mac OS Control Strip.



Avoid using highly-differenced source material. Some footage files can be temporally compressed, such as 
Animation-compressed QuickTime movies. (You set the temporal compression for a QuickTime movie by 
entering a value in the "keyframe every" field in the QuickTime compression dialog.) If you see your RAM 
preview build time getting longer on each frame, it may be the result of highly-differenced source material. 
JPEG, MJPEG, DV or similar compression schemes are frame-independent and do not exhibit this behavior.

Turn off Mac OS Virtual Memory. RAM preview works best when it's previewing from physical RAM.

THIRD PARTY COMPATIBILITY

Some third-party plug-ins, such as older versions of Final Effects' FE Glass and Mr. Mercury, can crash in the 
Windows version of After Effects 4.0. Older versions of ICE-enabled plug-ins may give errors when After Effects
4.0 Windows has performed a cache purge, such as when Edit>Purge>All is selected. Contact ICE for 
information about the availability of updated plug-ins.

After Effects 4.0's new caching and RAM previewing features can stress a plug-in's low-memory behavior in 
ways that were more unlikely to happen in previous versions of After Effects, which may affect the stability of 
third-party plug-ins. See the "Cache Preferences" section of this Read Me file for more details on how to tune 
After Effects' usage of RAM caching.

On Windows, selecting "About" to get information about a specific codec in the AVI Output Module Options 
dialog can cause a crash for some codecs, such as the Targa 2000 or the DVSoft codec.

On Windows using Targa 2000 3.0 or later, enabling both Video For Windows and QuickTime compatibility 
options in the Targa 2000 Service Selector can cause After Effects to hang or crash.

Total Impact MP accelerator systems designed for After Effects 3.x/Mac may not function in After Effects 4.0 – 
contact Total Impact for more information about compatibility with After Effects 4.0.

GENERAL NOTES

When converting 3.x or earlier projects containing Numbers, Path Text, or Basic Text effects, After Effects may 
not be able to convert the font name correctly – be sure to check any applications of these filters by selecting 
the effects' "options" dialog. If you're using Numbers, note that the placement of the text may have shifted.

When working with many masks on a layer (more than so 70 or so) you may need to increase the memory 
allocated to After Effects. Avoid nudging large numbers of selected masks.

Mesh Warp's (Production Bundle Only) information display shows the rows and columns of its mesh keyframes, 
which may be different from the current settings of the rows and columns slider. New keyframes will always be 
created at the density of the current time's rows and columns setting.

Interior points of a Mesh Warp can be dragged outside of the layer, but the Mesh Warp effect will only stretch 
the buffer accordingly if the boundary points are stretched as well.

The Diaquest DDR plug-in that shipped with After Effects 3.x Production Bundle is not designed to work in After 
Effects 4.0. While it will appear in the interface, its dialogs cannot be selected. Included on the After Effects 4.0 
CD is a plug-in for the Accom family of DDRs. Diaquest offers a plug-in for After Effects that supports additional 
DDR models from such manufacturers as Sierra Designs and Abekas. Contact Diaquest for more information.

The User Guide erroneously states that you can delete graph points from the Curves effect using the delete key.
You can delete a graph point by dragging it over its neighbors.



Photoshop plug-ins applied in After Effects (any effect listed in the menus as PS or PS+) are not retained when 
moving a project across platforms; whenever possible, use plug-ins designed for After Effects in projects that 
you intend to move to another platform.

In Particle Playground (Production Bundle Only), you can achieve more precision (and smoother collisions) for a
wall by using the Add Point tool on its mask to give it more control points When using Persistent and Ephemeral 
settings, avoid gradients containing alpha channels as your resulting values will be diminished by the alpha 
value.

The Preserve Underlying Transparency option does not function for Adjustment layers – if selected, the result 
will be the same as turning the Adjustment Layer's visibility off.

When pasting a mask from Photoshop, After Effects assumes that its images are at 72dpi – if you see your 
paths changing size unexpectedly, make sure that your image resolution is set to 72dpi when you copy the path 
from Photoshop.

After Effects cannot paste an Illustrator path that contains gradient mesh or other gradient information. You can 
work around this by removing the gradient information before copying in Illustrator.

Pasting of mask shapes from Adobe Illustrator and Photoshop is supported via a plug-in – if you cancel loading 
of plug-ins or otherwise disable them, you may lose the ability to paste masks from external applications. If you 
are unable to paste mask shapes from external applications, make sure the AIPaths.8BY (Windows)/Adobe 
Illustrator Paths (Mac) plug-in is installed in your plug-in folder.

After Effects 4.0 cannot open files saved in Illustrator 6.0 format by Illustrator 7.0 – the workaround is to re-save 
the files in Illustrator 7.0 format or re-save the file in any version using Illustrator 8.0.

The audio waveform (or any other graph) in the Time Layout window can be resized by dragging its border up 
and down. Note that the cursor may not change to a resize arrow.Position values as displayed in the Info floater 
are in original composition coordinates; for many items, a second coordinate will appear (X', Y') which will give 
you the coordinates using the ruler origin.

Command/Ctrl-clicking on a keyframe will change its interpolation type from linear to bezier or vice-versa. To 
select multiple keyframes, use shift-select instead of command/ctrl-select. Note that command/ctrl-clicking is 
used elsewhere in the application for discontiguous selection.

After Effects was not designed to be run from a remote server or from a read-only directory – install it on your 
local hard drive.

USING AFTER EFFECTS WITH MAC OS

There is a known problem in Mac OS 8.5 using third-party ADB devices, such as the hardware keys used by 
After Effects Production Bundle and other hardware-key protected applications. If you experience messages that
After Effects cannot locate its hardware key, obtain the free Mac OS 8.5.1 updater from Apple.

Some versions of the ATI Graphics Accelerator extension (such as 3.7.9) cause dimmed controls in some After 
Effects dialog boxes to draw as gray boxes; this is only cosmetic, but can be worked around by disabling or 
using a different version of the ATI Graphics Accelerator extension. 

It is not recommended that you run After Effects with Mac OS virtual memory as it can degrade performance of 
RAM preview and other After Effects features. If you do use Mac OS virtual memory and experience system 
instability, make sure that your hard disk drivers are up-to-date with your OS, especially if you are running Mac 
OS 8.5 or later.



Problems using context menus may be due to a conflict with Apple's "Context Menu Enabler" extension. Use the
Extension Manager control panel to disable "Context Menu Enabler" (not "Context Menu Extension".)

When performing RAM previews using Avid Media Composer-compressed QuickTime movies, you may 
experience unreported decompression failures. This can result blank or duplicated frames when working at 
decreased resolution. If this happens, change your composition's resolution to full or preview fewer frames. You 
can also work around the problem by using MoviePlayer to transcode your Avid movies to other software 
codecs, such as MJPEG-B.

Sometimes the on-line help system will fail to launch from the help menu on a fresh installation of After Effects; if
this happens, open the help manually by launching the QuickHelp application in your help folder.

USING AFTER EFFECTS WITH WINDOWS

After Effects 4.0 Production Bundle installs version 5.37 of the Rainbow Technologies Sentinel hardware key 
driver. While it is recommended that you install the latest version of the driver, some older Sentinel-protected 
applications (Such as Kinetix 3D Studio Max 1.x) may not be able to run with the new driver. After Effects 4.0 
will run with older versions of the driver if your other applications require it.

If you are using Windows NT®, you can specify configuration information for the hardware key using the 
Devices control panel. In most cases, the hardware key configures itself automatically and no user intervention 
is needed. For more documentation on these settings, see the hardware key help file in your system directory – 
it's located inside your NT system directory in system32/sentinel.hlp

After Effects can be run under Windows NT for Intel-based systems only. It will not run under other types of 
Windows NT such as Windows NT for DEC Alpha or Windows NT for PowerPC. While After Effects may run 
under FX!32 emulation on a DEC Alpha machine, it was not designed to be run in this environment.

If you use After Effects on a double-byte system such as Japanese, Chinese or Korean, be sure that you're 
running a double-byte version of QuickTime. Using the English version of QuickTime on these systems may 
cause common QuickTime dialogs to crash.

Adobe After Effects' initialization file (AfterFX.ini) is located in the Prefs subdirectory in the directory where After 
Effects is installed. The initialization file contains Windows-specific configuration information – see later in this 
file for documentation on its entries. The preferences file (AEPrefs4.txt) is also located in the same Prefs 
directory. Though this has a text extension, there is no human-readable information in this file.

When running on Windows 98, It is recommended that you turn off BIOS power saving options to avoid system 
crashes when working with imported AVI files. You can tell if you have BIOS power saving enabled by the 
presence of the Suspend command in your Start menu just above Shutdown.

CHANGING SETTINGS IN THE AFTER EFFECTS .INI FILE (WINDOWS 
ONLY)

The After Effects initialization file (AfterFX.ini) contains a few user-editable parameters for configuring After 
Effects. This section explains various settings in the AfterFX.ini file that can be useful for troubleshooting 
purposes. There are other entries in AfterFX.ini that are not documented – it is not recommended that you edit 
these. To restore the default .ini settings, delete the .ini file and a new one will be created the next time you run 
After Effects.

This section is for experienced After Effects and Video for Windows users only.



[codec] Section

KeepOpen=

After Effects normally initializes a compressor/decompressor (codec) only as needed, and releases it when not 
in use. Some hardware-based codecs exhibit problems when they are reinitialized frequently, so this setting 
leaves them initialized for the duration of a work session. The allowed value is a comma-separated list of four 
character IDs that identifies the codec, for example, MJPG

By default, After Effects installs this entry:
KeepOpen=MJPG

[After_Effects] Section

DontCheckSpaceDrives=

When rendering, After Effects will check the free space of a drive and warn the user when space is almost gone.
If you are using the NT virtual file system feature of a Perception Video Recorder, Hollywood Video Recorder, or
other product from Digital Processing Systems, you may get erroneous "File Not Found" or "Error getting file 
size" messages when rendering to the virtual file system. If this occurs, adding the appropriate drive letter to this
line in AfterFX.ini will prevent After Effects from checking the free space on the drive. By default, this value is set
to DontCheckSpaceDrives=P, as P is the default drive letter for the PVR. If your PVR, PAR or HVR is set up on 
another drive, change the letter in this entry. If you have multiple drives formatted for these capture cards, list 
them all with no commas in between.

PadAVIFiles=

Some hardware-specific AVI players expect their files to be constructed in a very specific way, where the video 
and audio samples are aligned to specific byte boundaries. If you receive errors from your player, you may want 
to set this value to 1 to turn this alignment on. Setting this value to 1 aligns AVI files to 512-byte boundaries, 
which is the value preferred by many such hardware players. If you know the specific byte boundary desired, 
(for example 2048) you can also set this value explicitly, i.e. PadAVIFiles=2048. Note that files constructed in 
this way may not be compatible with all applications.

Copyright (c) 1992-1999 Adobe Systems Incorporated. All rights reserved.
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